In my previous blog post I’ve adapted the INE’s CCIE Routing and Switching topology to be used with EVE-NG using IOSv (or vIOS) L3 images for routers and L2 images for switches.
Following the promise in that blog post, I’ve adapted the same topology using Cisco CSR1000v images for routers and IOSv L2 images for switches. There isn’t much to say about this topology since mostly is matching the original INE’s one for routers (including the configuration files) and the major difference is the utilization of virtual switches.
Since we’re using virtual switches, the configuration files for switches are still different. I’ve adapted these ones to match the interface names of IOSv-L2:
Real Switches – vIOS-L2
Fa0/1 - Gi0/0 - SW1 only connection to bridge Fa0/19 - Gi0/2 Fa0/20 - Gi0/3 Fa0/21 - Gi1/0 Fa0/22 - Gi1/1 Fa0/23 - Gi1/2 Fa0/24 - Gi1/3
For convenience, the switches topology looks like this in EVE-NG:
For routers, the interfaces stays the same since we’re using CSR1000v images.
Here is how the network topology looks like. No surprise here, just added for convenience:
If you don’t have the CSR1000v image added to your installation of EVE-NG, please download it (Cisco.com is a good starting point) and add it following these How-to:
HowTo add Cisco Cloud Service Router (CSR1000V NG) Denali and Everest
or
HowTo add Cisco Cloud Service Router (CSR1000V) – for pre Denali or Everest images.
If you’re curious I’m using csr1000v-universalk9.03.12.03.S.154-2.S3-std image when testing for this lab.
Before sharing the download links, a word of advice.
It may be that CSR1000v images are more stable and support all features when compared with IOSv-L3, however this comes with a cost in term of resources. Each node has by default 3GB RAM assigned and I wouldn’t recommend trying to decrease it.
Once the nodes boot up, the actual used RAM will be less, but still you need more resources to use CSR1000v.
My recommendation for 10 routers using CSR1000v images would be at least 16GB RAM assigned to the EVE-NG virtual machine. The same if you’re using EVE-NG on a bare metal machine.
Last but not least, somebody asked me when I’m going to provide the same topology with 20 routers.
No need. You can extend the default topology with as many devices as you want. The modified configuration files for labs with 20 routers are already modified and present in the archive you download. Just add the missing R11 until R20 devices.
If you encounter errors that are critical, please let me know and I’ll try to correct them.
Download files:
EVE-NG-INE-CCIEv5-Topology-CSR1000v.zip
INE-CCIEv5-RS-Initial-Configuration-for-EVE-NG-CSR1000v.zip
Happy labbing and let me know if you find these materials useful!
hey calin, were you able to use subinterfaces on the CSR1000v? traffic between two router subinterface with dot1q tagging doesn’t seem to work for me. Any idea?
R1 gi1 – bridge
R2 gi1 – bridge
Router1
interface GigabitEthernet1
no ip address
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet1.12
encapsulation dot1Q 12
ip address 192.168.12.1 255.255.255.0
Router2
interface GigabitEthernet1
no ip address
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet1.12
encapsulation dot1Q 12
ip address 192.168.12.2 255.255.255.0
R1#ping 192.168.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/48 ms
R1#ping 192.168.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R1#
R2#ping 192.168.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/43/210 ms
R2#ping 192.168.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R2#
After many hours of heartache, I have found a solution that worked for me! All I had to do was right-click the CSR1000v instance in Eve Ng -> Edit. In the middle of the “Edit Node” dialogue box, there are options to set the QEMU Version/Arch/Nic. I set the “QEMU Nic” to “vmxnet3” (it defaulted to tpl(e1000)). Now my CSRs can talk to each other through their DOT1Q sub-interfaces! They can also do so when cabled directly to each other (couldn’t before changed the above settings). I hope this helps someone else from going through the pain I did!
You need to add these 2 commands under GigabitEthernet1
Interface GigabitEthernet1
service instance 1 ethernet
encapsulation default
!
Hi
having the same problem as netninja, dot1q traffic dont pass between CSR routers. Untagged traffic works fine.
You need to add these 2 commands under GigabitEthernet1
Interface GigabitEthernet1
service instance 1 ethernet
encapsulation default
!
Having the same problem as Bjorn and Netninja, anyone know how to make it happen? Please send me an email [email protected] if you know how to fix this and don’t want to comment
Many thanks Nicholas for sharing, saved me some time
You need to add these 2 commands under GigabitEthernet1
Interface GigabitEthernet1
service instance 1 ethernet
encapsulation default
!
Thanks Calin for sharing this
Hi the downloaded files seem to have corrupted as they contain no data. Perhaps you can share it again? Thanks!
Not trying to steal views or anything (my blog is not and will not be monetized), but check out my topologies/configs. Very similar to Calin’s (gave him credit because I saw this first), but with some nice improvements to configuration management. It includes topologies and configs for IOU/IOSv/CSR1000v along with specially formatted configs to allow you to quickly switch between initial configs. I am using the CSR1000v topology for my CCIE studies and I love it.
https://nickccieprogress.blogspot.com/2019/01/method-post-using-eve-ng-for-ine-atc.html
Cool. Thanks Nicholas.
For those having issues with the CSR1000s not being able to ping each other via GigabitEthernet1, add these commands:
service instance 1 ethernet
encapsulation default
R1#sh run int g1
Building configuration…
Current configuration : 165 bytes
!
interface GigabitEthernet1
no ip address
negotiation auto
cdp enable
no mop enabled
no mop sysid
service instance 1 ethernet
encapsulation default
!
end
R1#sh run int g1.13
Building configuration…
Current configuration : 132 bytes
!
interface GigabitEthernet1.13
encapsulation dot1Q 13
ip address 155.1.13.1 255.255.255.0
ipv6 address 2001:155:1:13::1/64
end